Welcome to the University of Nebraska IT status page. Here you will find real-time information about status of our services.
Services with * indicate dashboard display only, 3rd Party component--to receive notifications go to the vendor status page.

More info at go.unl.edu/status or if you have questions or concerns, please contact ITS Computer Help Center 402-472-3970 or toll-free 866-472-3970 or Email: support@nebraska.edu
Follow IT Status via Twitter: @StatusNebraska
DNS - Nebraska.edu Domain Status: Resolved
Incident Report for IT
Resolved
Router Errors caused DNS services on the Nebraska.edu Domain to be briefly unavailable at 9:20 PM 5/14/17. All systems are operating normally. This issue is resolved.

Updated by Loren Frerichs
Posted May 15, 2017 - 14:06 CDT